标签归档:ARP

新安装的ROS怎么配置IP掩码和网关

新安装好的ROS,第一步就是需要先配置好IP,方便本地通过IP来配置或接上外网线路请求远程调试。

这一页面就简单说明ROS配置IP,掩码,网关。给初次接触ROS的朋友。
继续阅读

RouterOS(ROS)简单限速/单IP限速脚本

有时企业环境,或个人使用环境需要针对不同IP设置较多条不同限速,可以使用以下脚本批量处理后,再针对性的修改。
*脚本说明:“2 to 254”定义要设置受限IP的起始,后面“192.168.1.”定义IP段。后面的设置上传和下载,”128k/2M”中128k为上传限制,2M为下载限制。
继续阅读

RouterOS的ARP绑定操作详解

ros怎么绑定mac地址?

虽然主机在IP 网络中是通过IP地址通话,但实际上硬件地址(MAC地址)被用于主机到其他主机的数据传输。地址解析
协议Address resolution protocol (ARP) 是提供硬件地址与IP地址之间的解析。 每个路由器都一个ARP列表, 记录ARP信息,由IP地址和相符合的MAC地址构成,一般ARP提供动态的IP与 MAC地址对于关系,自动在ARP列表中产生。 路
由器通过ARP 列表的记录来回应各个主机的数据。我们也可通过静态的ARP记录,要求路由器只对静态的ARP 做回应。这样就可以避免出现如有用户擅自修改IP地址或者通过ARP病毒影响路由路由器工作。如通过下面的设置:
1. 在WinBox中将动态ARP设置为静态的ARP记录。
ARP-01

[[email protected]] ip arp> add address=192.168.1.248 interface=ether1-lan mac-address=00:21:00:56:00:12
同样的我们可以使用:
将所有的的ARP记录修改为静态的。

2.设置ether1-lan interface 仅回应静态 ARP的请求,arp=reply-only:
arp-02
脚本操作如下:

[[email protected]] > interface ethernet set ether2 arp=reply-only

ARP 双向绑定事例:
首先将所有/ip arp列表中的所有LAN口的 ARP信息变为静态的,我们可以通过脚本做批处理的修改。注意,可能通过脚本命令不一定能将所有的内网的ARP参数修改完,可能需要手动添加。

:foreach i in [/ip arp find dynamic=yes interface=LAN] do={
/ip arp add copy-from=$i}

然后设置 LAN 的网卡为:disabled
如果 ARP 功能在接口上被关闭,例如:使用 arp=disabled,来至客户端的 ARP 请求将不被路由器回应,因此
必须添加静态的 ARP 才行。 例如,通过 arp 命令将路由器的 IP和 MAC 地址必须添加到 windows工作站中:

[[email protected]] ip arp> /interface ethernet set LAN arp=disabled

现在路由器已经绑定了内网主机的所有 IP 地址后,现在需要对 Windows 电脑做对路由器绑定的设置
C:\> arp -s 10.5.8.254 00-aa-00-62-c6-09
也可以编辑windows 自己的批处理文件(.dat)操作