DDNS动态域名脚本-ROS RouterOS 中设置花生壳

在ROS中使用花生壳动态域名解析服务,需要由脚本(Scripts)来实现,再通过日程(Scheduler)来进行定时的刷新。

脚本实现的方法很多,以下为一个自动获取拨号IP地址并提交到花生壳动态域名解析的例子:
打开winbox等待到ROS,选择System-Scripts,添加新的脚本peanutddns
在Source栏输入:

local ipaddr
local server "http://.oray.com"
local domain "域名"
local par "/ph/update?&hostname=$domain&myip=$ipaddr"
local users "用户名"
local paswd "密码"
:set ipaddr [/ip address get [/ip address find interface=pppoe-out1] address]
:set ipaddr [:pick $ipaddr 0 ([len $ipaddr] -3)]
/tool fetch url=($server . $par) mode=http user=$users password=$paswd

如图:
hsk_ddns_1
脚本添加完成后,需要新增日程来自动执行,通过System- Scheduler新增新的日程
在Interval输入执行间隔,建议如下:
免费服务30分钟;
专业级别5分钟;
商业级别3分钟;
旗舰级别1分钟;
间隔时间越短,在ADSL重新拨号后解析生效时间越快

在On Event栏输入:

:execute peanutddns

hsk_ddns_2

5.X测试可用

ROS端口映射教程(目标地址转换):http://www.roszj.com/422.html